archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-sandi / repos / community-x86_64 / PKGBUILD
blob39a007c81e973275f63bf3a7bb9afe2c71e9b62a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=sandi
5 pkgname=haskell-sandi
6 pkgver=0.5
7 pkgrel=385
8 pkgdesc="Data encoding library"
9 url="https://hackage.haskell.org/package/sandi"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-conduit')
13 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck'
14              'haskell-tasty-th')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('8abff3496d0d3f082f12416eea3189e06d1663fe78d996159396ab944389b2a816853c0191edced3b176fc506dac60e9ce84347ecaf2c255e5ec0d6b1590c012')
18 prepare() {
19     cd $_hkgname-$pkgver
20     echo -e "import Distribution.Simple\nmain = defaultMain" > Setup.hs
23 build() {
24     cd $_hkgname-$pkgver
25     
26     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29             -fwith-conduit
30     runhaskell Setup build $MAKEFLAGS
31     runhaskell Setup register --gen-script
32     runhaskell Setup unregister --gen-script
33     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38     cd $_hkgname-$pkgver
39     runhaskell Setup test --show-details=direct
42 package() {
43     cd $_hkgname-$pkgver
44     
45     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47     runhaskell Setup copy --destdir="$pkgdir"
48     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE