archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-scientific / trunk / PKGBUILD
blob93fe5965a77f33826215386f302a6b24e4f8b9f8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=scientific
5 pkgname=haskell-scientific
6 pkgver=0.3.7.0
7 pkgrel=91
8 pkgdesc="Numbers represented using scientific notation"
9 url="https://github.com/basvandijk/scientific"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-hashable' 'haskell-integer-logarithms' 'haskell-primitive')
13 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-smallcheck' 'haskell-tasty' 'haskell-tasty-hunit'
14              'haskell-tasty-quickcheck' 'haskell-tasty-smallcheck')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('dbd13060a6d1d101138715b4106382a78d115cff247859cb6f83aca3cdb6f6caf8a2c52d7ae99be64845c5e4a7959940bbf31df6265b15079c236f193b087865')
18 prepare() {
19     cd $_hkgname-$pkgver
20     uusi -u hashable $_hkgname.cabal
23 build() {
24     cd $_hkgname-$pkgver
25     
26     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29             -f-integer-simple -f-bytestring-builder
30     runhaskell Setup build $MAKEFLAGS
31     runhaskell Setup register --gen-script
32     runhaskell Setup unregister --gen-script
33     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38     cd $_hkgname-$pkgver
39     runhaskell Setup test --show-details=direct
42 package() {
43     cd $_hkgname-$pkgver
44     
45     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47     runhaskell Setup copy --destdir="$pkgdir"
48     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE