archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-shellmet / trunk / PKGBUILD
blob1233033608c4b789c000d35025a901febd8c545a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: berberman <hatsue@typed.icu>
4 _hkgname=shellmet
5 pkgname=haskell-shellmet
6 pkgver=0.0.4.1
7 pkgrel=30
8 pkgdesc="Shellmet provides easy and convenient way to call shell commands from Haskell programs."
9 url="https://github.com/kowainik/shellmet"
10 license=('MPL2')
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc' 'uusi' 'haskell-doctest' 'haskell-glob' 'haskell-markdown-unlit')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha512sums=('ddb29dc2f7368b0bf3e3984eec4120e01609c23aa02191b6a742f1f59f71b10c9bd33c5d486b1e375909acf81c6aea4ac9c89d3e20289377fc43b8e119ccbb05')
17 prepare(){
18   cd $_hkgname-$pkgver
19   gen-setup
22 build() {
23   cd $_hkgname-$pkgver    
24     
25   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29     --ghc-option='-pie'
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"
49   install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
52   mv "$pkgdir"/usr/bin/{,shellmet-}readme