archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-sqlite-simple / trunk / PKGBUILD
blob65de0ca231bc1abcab227ab19280d0d8a79763ce
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=sqlite-simple
4 pkgname=haskell-sqlite-simple
5 pkgver=0.4.18.2
6 pkgrel=36
7 pkgdesc="Mid-Level SQLite client library"
8 url="https://github.com/nurpax/sqlite-simple"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-only' 'haskell-attoparsec' 'haskell-blaze-builder'
12          'haskell-blaze-textual' 'haskell-direct-sqlite')
13 makedepends=('ghc' 'haskell-hunit' 'haskell-base16-bytestring')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('dc15b1a7dd5428f218d40cd8b3e51d4b559d5d86c52639ba3f0f811813735d91')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie'
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE