archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-statistics / trunk / PKGBUILD
blob27d511e07ec676a5f31915fe8f5c1d5333bd8004
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=statistics
5 pkgname=haskell-statistics
6 pkgver=0.16.2.0
7 pkgrel=2
8 pkgdesc="A library of statistical types, data, and functions"
9 url="https://github.com/haskell/statistics"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-aeson' 'haskell-async' 'haskell-data-default-class'
13          'haskell-dense-linear-algebra' 'haskell-math-functions' 'haskell-mwc-random'
14          'haskell-parallel' 'haskell-primitive' 'haskell-random' 'haskell-vector'
15          'haskell-vector-algorithms' 'haskell-vector-binary-instances' 'haskell-vector-th-unbox')
16 makedepends=('ghc' 'haskell-hunit' 'haskell-quickcheck' 'haskell-erf' 'haskell-ieee754'
17              'haskell-tasty' 'haskell-tasty-expected-failure' 'haskell-tasty-hunit'
18              'haskell-tasty-quickcheck')
19 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
20 sha512sums=('934928e5f8f4f38fe1755a5d16d9a4653401a983d86b2f0fc7f9d4ba90b0b05cf19caec2f4e48874fc7995450a016fa9b45dadc0d6316807fbf19ed75d14c38b')
22 build() {
23     cd $_hkgname-$pkgver
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
42     
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE