1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=storable-tuple
5 pkgname=haskell-storable-tuple
8 pkgdesc="Storable instance for pairs and triples"
9 url="http://code.haskell.org/~thielema/storable-tuple/"
12 depends=('ghc-libs' 'haskell-storable-record' 'haskell-utility-ht' 'haskell-base-orphans')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('3346447a26b805132d5eedbb0ef6d8f8422c3f81d2ba23a02443fb3519ce9fe5c3433f04def616f4748dbc3e3d6ced5a9322dcdce4365ba8eab8709f06bb1b0a')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 runhaskell Setup build $MAKEFLAGS
25 runhaskell Setup register --gen-script
26 runhaskell Setup unregister --gen-script
27 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36 runhaskell Setup copy --destdir="$pkgdir"
37 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE