archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-store / trunk / PKGBUILD
blob8c9f8dc8b68ff73107a769e9f7d445ca0411ffe4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=store
4 pkgname=haskell-store
5 pkgver=0.7.16
6 pkgrel=48
7 pkgdesc="Fast binary serialization"
8 url="https://github.com/mgsloan/store"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-async' 'haskell-base-orphans' 'haskell-base64-bytestring'
12          'haskell-bifunctors' 'haskell-contravariant' 'haskell-cryptohash' 'haskell-free'
13          'haskell-hashable' 'haskell-hspec' 'haskell-hspec-smallcheck' 'haskell-lifted-base'
14          'haskell-monad-control' 'haskell-mono-traversable' 'haskell-network' 'haskell-primitive'
15          'haskell-resourcet' 'haskell-safe' 'haskell-smallcheck' 'haskell-store-core'
16          'haskell-syb' 'haskell-th-lift' 'haskell-th-lift-instances' 'haskell-th-orphans'
17          'haskell-th-reify-many' 'haskell-th-utilities' 'haskell-unordered-containers'
18          'haskell-vector' 'haskell-void')
19 makedepends=('ghc' 'uusi' 'haskell-clock' 'haskell-hspec-discover')
20 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
21 sha512sums=('0b8c79cf9c0cc489535a9ca9a17cd2e4e16c3828d9327b2127558abcabed363c30b834f88d002053d3a8ddac0ba08cac53e78c95ef683e04973fa4842d150d54')
23 prepare() {
24     cd $_hkgname-$pkgver
25     uusi -d nats $_hkgname.cabal
28 build() {
29     cd $_hkgname-$pkgver
31     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
32         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
33         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
34             -f-comparison-bench -f-small-bench
35     runhaskell Setup build $MAKEFLAGS
36     runhaskell Setup register --gen-script
37     runhaskell Setup unregister --gen-script
38     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
39     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
42 check() {
43     cd $_hkgname-$pkgver
44     runhaskell Setup test --show-details=direct
47 package() {
48     cd $_hkgname-$pkgver
50     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
51     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
52     runhaskell Setup copy --destdir="$pkgdir"
53     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
54     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE