archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-tasty-smallcheck / repos / community-x86_64 / PKGBUILD
blob0154c2c88e53a0eddd85ba62bdd89f9db9d21b18
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=tasty-smallcheck
4 pkgname=haskell-tasty-smallcheck
5 pkgver=0.8.2
6 pkgrel=395
7 pkgdesc="SmallCheck support for the Tasty test framework"
8 url="https://github.com/feuerbach/tasty"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-optparse-applicative' 'haskell-smallcheck' 'haskell-tagged'
12          'haskell-tasty')
13 makedepends=('ghc')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('ff816280315e26d20210f0dcbf55e32780aa9ef455d8d00b146d9daeed6afec5b6593cd8a8dc0b7c0bc7ff77da75f065f9c7253494f2c47150e2b7a6aa29fc6a')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE