1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-text-metrics
7 pkgdesc="Calculate various string metrics efficiently"
8 url="https://github.com/mrkkrp/text-metrics"
11 depends=('ghc-libs' 'haskell-vector')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-hspec')
13 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
14 sha512sums=('2e520de8c0676f15a96e166e5b6105c835d6c3041e200595cba29b549d25edb3f1c04fd0b988c786eb92bddcdbdc776a110cb369e84ec7c9c0a8ff9f085d816e')
18 uusi -u vector $_hkgname.cabal
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE.md