archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-th-expand-syns / repos / community-x86_64 / PKGBUILD
blobe29da227e28b75acf088c11a20edb1d742f84c57
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=th-expand-syns
4 pkgname=haskell-th-expand-syns
5 pkgver=0.4.11.0
6 pkgrel=5
7 pkgdesc="Expands type synonyms in Template Haskell ASTs"
8 url="https://hackage.haskell.org/package/th-expand-syns"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-syb' 'haskell-th-abstraction')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('572d2fd60677a07cad15363e5a6b533632f494f2bc2ef0ed5209e255415f9e5d502935820f4f52adc91309a7ffef3e98e7158d3c84a08d368e1e394c0c7a4a07')
16 build() {
17     cd $_hkgname-$pkgver
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 check() {
30     cd $_hkgname-$pkgver
31     runhaskell Setup test --show-details=direct
34 package() {
35     cd $_hkgname-$pkgver
37     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39     runhaskell Setup copy --destdir="$pkgdir"
40     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
41     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE