archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-th-lift-instances / trunk / PKGBUILD
blob54efe4d51958ecb9c95d823976889d2572f38aa8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=th-lift-instances
4 pkgname=haskell-th-lift-instances
5 pkgver=0.1.20
6 pkgrel=24
7 pkgdesc="Lift instances for template-haskell for common data types."
8 url="https://github.com/bennofs/th-lift-instances/"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-th-lift' 'haskell-vector')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('bb43b13df8fb939a79a3fc1099900fcaa8741eb61b8f5574b7d7b68c220acc0cbb9fa7517b22ad34f006da7a1c25c08d1237309f8f98d79ca4d00dad345b28cb')
16 build() {
17     cd $_hkgname-$pkgver
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 package() {
30     cd $_hkgname-$pkgver
31     
32     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
33     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
34     runhaskell Setup copy --destdir="$pkgdir"
35     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE