archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-time-compat / repos / community-x86_64 / PKGBUILD
blob0154173dcd4854e95e06f4a9d83fcbee13d94121
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=time-compat
4 pkgname=haskell-time-compat
5 pkgver=1.9.6.1
6 pkgrel=75
7 pkgdesc="Compatibility package for time"
8 url="https://github.com/phadej/time-compat"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-base-orphans' 'haskell-hashable')
12 makedepends=('ghc' 'uusi' 'haskell-base-compat' 'haskell-hunit' 'haskell-quickcheck' 'haskell-tagged'
13              'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('ca0b19aa5e7948fd7d9fbd8ff5e1b0f93a2d8d410d515e7078b40370e7d9fc363c111d53551d57a0320efb0894bcc2210afa8fc04da9f003ded626f53b7e58ea')
17 prepare() {
18     cd $_hkgname-$pkgver
19     gen-setup
20     uusi -u base-compat -u hashable $_hkgname.cabal
23 build() {
24     cd $_hkgname-$pkgver    
25     
26     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 check() {
37     cd $_hkgname-$pkgver
38     runhaskell Setup test --show-details=direct
41 package() {
42     cd $_hkgname-$pkgver
43     
44     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46     runhaskell Setup copy --destdir="$pkgdir"
47     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
48     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE