archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-tuple-th / repos / community-x86_64 / PKGBUILD
blob660fbb8271c9fc57b5bab82b971af7c4007b54e1
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=tuple-th
5 pkgname=haskell-tuple-th
6 pkgver=0.2.5
7 pkgrel=24
8 pkgdesc="Generate (non-recursive) utility functions for tuples of statically known size"
9 url="https://github.com/DanielSchuessler/tuple-th"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('725864ef973188f6db0be431358a87dca630c8c3be554f651933b1198c06568a1fba34f78763ff639292632c7a848839c1f4d3236a3d8bd96e1f10573b01508e')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE