archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-uniplate / repos / community-x86_64 / PKGBUILD
blob8173957cf426b58c48ca5058c0068c02f9a865ef
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=uniplate
5 pkgname=haskell-uniplate
6 pkgver=1.6.13
7 pkgrel=181
8 pkgdesc="Help writing simple, concise and fast generic operations."
9 url="https://github.com/ndmitchell/uniplate#readme"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-hashable" "haskell-syb" "haskell-unordered-containers")
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('8cab820d40b318c7483319de4174bdbd3637e1c93f42bc6b796c6a8a1fa93331c0a2ff3b7c77f6a2ec0509fb48bb922ef732c7d79e8e6bcf7987bde949459310')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23             -fseparate_syb -ftypeable_fingerprint
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 package() {
32     cd $_hkgname-$pkgver
33     
34     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36     runhaskell Setup copy --destdir="$pkgdir"
37     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE