archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-x509-store / repos / community-x86_64 / PKGBUILD
blobd7f8418f8825852ddac6b698c70c3a386cf006d9
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=x509-store
5 pkgname=haskell-x509-store
6 pkgver=1.6.9
7 pkgrel=60
8 pkgdesc="X.509 collection accessing and storing methods"
9 url="https://github.com/vincenthz/hs-certificate"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-asn1-encoding" "haskell-asn1-types" "haskell-cryptonite"
13          "haskell-pem" "haskell-x509")
14 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('10d0f4a4cb88852d8fd79676908e712ecc19a1b54cae9245f976eea1382abc03392e7fa593973180e6cfd9eb3c1de7133cf738a7c8b3a86d02278d2777d3af96')
18 build() {
19     cd $_hkgname-$pkgver
20     
21     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
23         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 check() {
32     cd $_hkgname-$pkgver
33     runhaskell Setup test --show-details=direct
36 package() {
37     cd $_hkgname-$pkgver
38     
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE