archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-x509-system / trunk / PKGBUILD
blob937ab9a694e6b1d2143f93a88794f20ca88aaacc
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=x509-system
5 pkgname=haskell-x509-system
6 pkgver=1.6.7
7 pkgrel=63
8 pkgdesc="Handle per-operating-system X.509 accessors and storage"
9 url="https://github.com/vincenthz/hs-certificate"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-pem" "haskell-x509" "haskell-x509-store")
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('8414d8f6d0e704419ccdd6832522480022bb15ac225b6bd9cf5f2d8fffb7f979d414bcb5c465f4d73d9eef40210ef9aa5da51aea9eed2ce245d2b44daf2c415e')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE