1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-xml-hamlet
8 pkgdesc="Hamlet-style quasiquoter for XML content"
9 url="http://www.yesodweb.com/"
12 depends=('ghc-libs' "haskell-shakespeare"
13 "haskell-xml-conduit")
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('3a186ec01dbf5f84b294d5dcf01f595826bbf26d6eb84f41bfa8341a4756a6aeb48f7fd7d1bd4398b74c421ed18a0f5908a49864cca7348d54b50b92cbe93007')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24 runhaskell Setup build $MAKEFLAGS
25 runhaskell Setup register --gen-script
26 runhaskell Setup unregister --gen-script
27 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36 runhaskell Setup copy --destdir="$pkgdir"
37 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE