archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-yesod-static / repos / community-x86_64 / PKGBUILD
blobd9105cb45bca9fefb593e879fb6603498a58603e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=yesod-static
5 pkgname=haskell-yesod-static
6 pkgver=1.6.1.0
7 pkgrel=604
8 pkgdesc="Static file serving subsite for Yesod Web Framework."
9 url="http://www.yesodweb.com/"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-async' 'haskell-attoparsec' 'haskell-base64-bytestring'
13          'haskell-blaze-builder' 'haskell-conduit' 'haskell-cryptonite'
14          'haskell-cryptonite-conduit' 'haskell-css-text' 'haskell-data-default'
15          'haskell-file-embed' 'haskell-hashable' 'haskell-hjsmin' 'haskell-http-types'
16          'haskell-memory' 'haskell-mime-types' 'haskell-rio' 'haskell-unix-compat'
17          'haskell-unordered-containers' 'haskell-wai' 'haskell-wai-app-static' 'haskell-yesod-core')
18 makedepends=('ghc' 'haskell-hspec' 'haskell-hunit' 'haskell-wai-extra' 'haskell-yesod-test')
19 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
20 sha512sums=('66037ec28eac83e374161c1b306a4d20805ecb35ccfc4878e7894d961daaf30d9936c6e209641ff323d7e3dd5626f5a24a12915d4205417c496e272a2e969f6e')
22 build() {
23     cd $_hkgname-$pkgver
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
42     
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE