archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-zinza / repos / community-x86_64 / PKGBUILD
blobb43f33245b6b0fd12e0de6a4c390fe19917f971c
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=zinza
4 pkgname=haskell-zinza
5 pkgver=0.2
6 pkgrel=135
7 pkgdesc="Typed templates with jinja like syntax"
8 url="https://github.com/phadej/zinza"
9 license=("GPL")
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
13              'haskell-tasty-golden' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('68cb9c3cb5c81c82a81a63d012869d1ec3fddda89be0bd5f8fc0aa8f2a64c4eb')
17 prepare() {
18   cd $_hkgname-$pkgver
19   gen-setup
20   uusi -u base -u QuickCheck -u tasty $_hkgname.cabal
23 build() {
24   cd $_hkgname-$pkgver
26   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
30     --ghc-option='-pie'
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE