archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-zlib / repos / community-x86_64 / PKGBUILD
blobbe3ca801df78d82ed6ba159a9ff3b0be62cfae7d
1 # Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
2 # Maintainer: Colin Woodbury <colingw@gmail.com>
4 pkgname=haskell-zlib
5 pkgver=0.6.3.0
6 pkgrel=38
7 pkgdesc="Compression and decompression in the gzip and zlib formats"
8 url="https://hackage.haskell.org/package/zlib"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'zlib')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-tasty' 'haskell-tasty-quickcheck')
13 source=(https://hackage.haskell.org/packages/archive/zlib/${pkgver}/zlib-${pkgver}.tar.gz)
14 sha512sums=('95daae13c5d5458fd7c610ce4cc686dc7af477364c4dcf3d31abede84f6e4b4e70ea255f7ded586d46d9bb6298d19c93b8856eec16c6002265ed076e52bf9a21')
16 prepare() {
17     cd zlib-$pkgver
18     gen-setup
21 build() {
22     cd zlib-$pkgver
23     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
24         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
25         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
26             -f-non-blocking-ffi -fpkg-config -f-bundled-c-zlib
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register   --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd zlib-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd zlib-$pkgver
41     
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/${pkgname}/LICENSE