archrelease: copy trunk to community-any
[ArchLinux/community.git] / higan / trunk / PKGBUILD
blob9a9099d6dfabf25617799798c6d2f841703021f7
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=higan
4 pkgver=110
5 pkgrel=2
6 pkgdesc='A multi-system emulator focused on accuracy, preservation, and configurability'
7 arch=(x86_64)
8 url=https://byuu.org/
9 license=(GPL3)
10 depends=(
11   gcc-libs
12   glibc
13   libao
14   libasound.so
15   libgl
16   libpulse-simple.so
17   libpulse.so
18   libudev.so
19   libx11
20   libxext
21   libxrandr
22   libxv
23   openal
24   qt5-base
25   sdl2
27 makedepends=(
28   git
30 source=(
31   git+https://github.com/byuu/higan.git#tag=483c5781fc7e853d6ae9f179303cca16af09134f
32   higan-flags.patch
33   higan-paths.patch
35 sha256sums=('SKIP'
36             'bf84cfa9f2499a187dca613272fadf267fd3e2c29b615af74b1e219bd8c3247c'
37             '9cc20274c420a05667f35bdc9db313f1a6ce47d964dbf0cef62d85c46a4170a4')
39 pkgver() {
40   cd higan
42   git describe --tags | sed 's/^v//'
45 prepare() {
46   cd higan
48   patch -Np1 -i ../higan-flags.patch
49   patch -Np1 -i ../higan-paths.patch
50   sed 's|/usr/local/lib/qt5/bin/moc|moc|' -i hiro/GNUmakefile
53 build() {
54   cd higan
56   make -C higan hiro=qt5
57   make -C icarus hiro=qt5
60 package() {
61   install -dm 755 "${pkgdir}"/usr/share/{higan,icarus}
63   install -Dm 755 higan/higan/out/higan -t "${pkgdir}"/usr/bin/
64   install -Dm 644 higan/higan/target-higan/resource/higan.desktop -t "${pkgdir}"/usr/share/applications/
65   install -Dm 644 higan/higan/target-higan/resource/higan.svg -t "${pkgdir}"/usr/share/pixmaps/
66   cp -dr --no-preserve='ownership' higan/higan/System "${pkgdir}"/usr/share/higan/Templates
68   install -Dm 755 higan/icarus/out/icarus -t "${pkgdir}"/usr/bin/
69   install -Dm 644 higan/icarus/data/icarus.desktop -t "${pkgdir}"/usr/share/applications/
70   install -Dm 644 higan/icarus/data/icarus.svg -t "${pkgdir}"/usr/share/pixmaps/
71   cp -dr --no-preserve='ownership' higan/icarus/Database higan/icarus/Firmware "${pkgdir}"/usr/share/icarus/
74 # vim: ts=2 sw=2 et: