1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
6 pkgdesc='A multi-system emulator focused on accuracy, preservation, and configurability'
31 git+https://github.com/byuu/higan.git#tag=483c5781fc7e853d6ae9f179303cca16af09134f
36 'bf84cfa9f2499a187dca613272fadf267fd3e2c29b615af74b1e219bd8c3247c'
37 '9cc20274c420a05667f35bdc9db313f1a6ce47d964dbf0cef62d85c46a4170a4')
42 git describe --tags | sed 's/^v//'
48 patch -Np1 -i ../higan-flags.patch
49 patch -Np1 -i ../higan-paths.patch
50 sed 's|/usr/local/lib/qt5/bin/moc|moc|' -i hiro/GNUmakefile
56 make -C higan hiro=qt5
57 make -C icarus hiro=qt5
61 install -dm 755 "${pkgdir}"/usr/share/{higan,icarus}
63 install -Dm 755 higan/higan/out/higan -t "${pkgdir}"/usr/bin/
64 install -Dm 644 higan/higan/target-higan/resource/higan.desktop -t "${pkgdir}"/usr/share/applications/
65 install -Dm 644 higan/higan/target-higan/resource/higan.svg -t "${pkgdir}"/usr/share/pixmaps/
66 cp -dr --no-preserve='ownership' higan/higan/System "${pkgdir}"/usr/share/higan/Templates
68 install -Dm 755 higan/icarus/out/icarus -t "${pkgdir}"/usr/bin/
69 install -Dm 644 higan/icarus/data/icarus.desktop -t "${pkgdir}"/usr/share/applications/
70 install -Dm 644 higan/icarus/data/icarus.svg -t "${pkgdir}"/usr/share/pixmaps/
71 cp -dr --no-preserve='ownership' higan/icarus/Database higan/icarus/Firmware "${pkgdir}"/usr/share/icarus/