archrelease: copy trunk to community-any
[ArchLinux/community.git] / hoel / trunk / PKGBUILD
blob53a304d7a1161b9c21016680ae4ca08118d03a4c
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=hoel
4 pkgver=1.4.27
5 pkgrel=1
6 pkgdesc='C Database abstraction library with json based language'
7 arch=(x86_64)
8 url=https://github.com/babelouest/hoel
9 license=(LGPL2.1)
10 depends=(
11   glibc
12   jansson
13   liborcania.so
14   libyder.so
16 makedepends=(
17   cmake
18   doxygen
19   git
20   graphviz
21   mariadb-libs
22   ninja
23   postgresql-libs
24   sqlite
26 optdepends=(
27   'postgresql-libs: PostgreSQL support'
28   'mariadb-libs: MariaDB support'
29   'sqlite: SQLite support'
31 provides=(libhoel.so)
32 _tag=be59ba35b1a6778d8b1a9c6d1788df17e6e92669
33 source=(git+https://github.com/babelouest/hoel.git#tag=${_tag})
34 validpgpkeys=(8405B02FCC28EF9744C8F253FE82139440BD22B9) # Nicolas Mora <nicolas@babelouest.org>
35 b2sums=(SKIP)
37 pkgver() {
38   cd hoel
39   git describe --tags | sed 's/^v//'
42 build() {
43   cmake -S hoel -B build -G Ninja \
44     -DCMAKE_BUILD_TYPE=None \
45     -DCMAKE_INSTALL_PREFIX=/usr \
46     -DBUILD_HOEL_DOCUMENTATION=ON
47   ninja -C build doc
50 package() {
51   DESTDIR="${pkgdir}" ninja -C build install
52   install -dm 755 "${pkgdir}"/usr/share/doc/hoel
53   cp -dr --no-preserve=ownership hoel/doc/html "${pkgdir}"/usr/share/doc/hoel/
56 # vim: ts=2 sw=2 et: