archrelease: copy trunk to community-any
[ArchLinux/community.git] / httping / repos / community-x86_64 / PKGBUILD
blob399e2af1f5a3468de9452d1684968009d9eec766
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: brent s. <bts[at]square-r00t[dot]net>
3 # Contributor: Joris Steyn <jorissteyn@gmail.com>
4 # Contributor: Ondrej Kucera <ondrej.kucera@centrum.cz>
6 pkgname=httping
7 pkgver=2.9
8 pkgrel=1
9 pkgdesc='A ping-like tool for http-requests'
10 url='https://www.vanheusden.com/httping/'
11 arch=('x86_64')
12 license=('GPL3')
13 depends=('openssl' 'ncurses' 'fftw')
14 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/folkertvanheusden/HTTPing/archive/refs/tags/v${pkgver}.tar.gz")
15 sha512sums=('74d4a98590b6862a2f15fffdf3bc58e3226a94c7aebbe60135695397b20e6cb71fe8c2af75b8525724f2f9ce6530d1f8eecd3193bc50f31d254bbb9903615019')
17 build() {
18   cd HTTPing-${pkgver}
19   ./configure --with-tfo
20   make
23 package() {
24   cd HTTPing-${pkgver}
25   make DESTDIR="${pkgdir}" install
28 # vim: ts=2 sw=2 et: