archrelease: copy trunk to community-any
[ArchLinux/community.git] / hyphen-fr / trunk / PKGBUILD
blobf02f1c305c8605bffb34a5e089cc2e1ecbca7dc1
1 # Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
3 pkgname=hyphen-fr
4 pkgver=3.0
5 pkgrel=5
6 pkgdesc="French hyphenation rules"
7 arch=('any')
8 url='https://www.gammalecte.net/home.php?prj=fr'
9 license=('LGPL')
10 optdepends=('hyphen: offers hyphenation library functions')
11 source=("https://grammalecte.net/download/fr/hyph-fr-v${pkgver}.zip")
12 sha256sums=('c36e530bbd12d7b36b1238feaf4055dcb05fee0e139ed441953557857de4f363')
14 package() {
15   cd "${srcdir}"
16   install -dm755 ${pkgdir}/usr/share/hyphen
17   install -m644 hyph_fr.dic ${pkgdir}/usr/share/hyphen/hyph_fr_FR.dic
19   pushd ${pkgdir}/usr/share/hyphen/
20   fr_FR_aliases="fr_BE fr_CA fr_CH fr_LU"
21   for lang in ${fr_FR_aliases}; do
22         ln -s hyph_fr_FR.dic hyph_${lang}.dic
23   done
25   popd
27   # the symlinks
28   install -dm755 ${pkgdir}/usr/share/myspell/dicts
29   pushd ${pkgdir}/usr/share/myspell/dicts
30     for file in ${pkgdir}/usr/share/hyphen/*; do
31       ln -sv /usr/share/hyphen/$(basename ${file}) .
32     done
33   popd
34   
35   # docs
36   install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
37   install -m644 README_hyph_fr-${pkgver}.txt \
38                 ${pkgdir}/usr/share/doc/${pkgname}/README_hyph_fr_FR.txt