archrelease: copy trunk to community-any
[ArchLinux/community.git] / ifuse / repos / community-x86_64 / PKGBUILD
blob23d063963341274c402c9907ec565421183bcac3
1 # Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Contributor: Carlo Abelli <carlo@abelli.me>
3 # Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
4 # Contributor: Federico Cinelli <cinelli@aur.archlinux.org>
5 # Contributor: Thomas Dziedzic  < gostrc at gmail >
6 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
8 pkgname=ifuse
9 pkgver=1.1.4
10 pkgrel=4
11 pkgdesc="A fuse filesystem to access the contents of an iPhone or iPod Touch"
12 url="https://libimobiledevice.org/"
13 arch=(x86_64)
14 license=(LGPL2.1)
15 depends=(
16   fuse2
17   libimobiledevice
18   libplist
19   usbmuxd
21 makedepends=(git)
22 _commit=33434dec21198de11cea78325321d55ebb7bd71f  # tags/1.1.4
23 source=("git+https://github.com/libimobiledevice/ifuse#commit=$_commit")
24 b2sums=('SKIP')
26 pkgver() {
27   cd ifuse
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 build() {
32   cd ifuse
33   ./autogen.sh --prefix=/usr
34   make
37 package() {
38   cd ifuse
39   make DESTDIR="$pkgdir" install
42 # vim:set sw=2 sts=-1 et: