archrelease: copy trunk to community-any
[ArchLinux/community.git] / jo / trunk / PKGBUILD
blob4e427853d2d69a547ced126287be0c739791fddc
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Sebastian LaVine <mail@smlavine.com>
3 # Contributor: Lance Chen <cyen0312@gmail.com>
5 pkgname=jo
6 pkgver=1.9
7 pkgrel=1
8 pkgdesc='JSON output from a shell'
9 arch=('x86_64')
10 url='https://github.com/jpmens/jo'
11 license=('GPL2')
12 depends=('glibc')
13 makedepends=('git' 'pandoc')
14 _commit='2cc476178198774ad6bea89be0b9e4ed2d4bf4c5'
15 source=("$pkgname::git+$url.git#commit=$_commit")
16 b2sums=('SKIP')
18 pkgver() {
19   cd "$pkgname"
21   git describe --tags | sed 's/^v//'
24 build() {
25   cd "$pkgname"
27   autoreconf -vfi
29   ./configure \
30     --prefix=/usr \
31     bashcompdir=/usr/share/bash-completion/completions
33   make all
36 check() {
37   cd "$pkgname"
39   make -k check
42 package() {
43   cd "$pkgname"
45   make DESTDIR="$pkgdir" install
47   # TODO: patch in autotools, or just leave as is ...
48   cd "$pkgdir/usr/share/bash-completion/completions"
49   mv jo.bash jo