archrelease: copy trunk to community-any
[ArchLinux/community.git] / kodi-platform / trunk / PKGBUILD
blob406f023c15a74e0f69596af379a8221604476c23
1 # Maintainer: BlackEagle <ike.devolder@gmail.com>>
3 pkgname=kodi-platform
4 _commit=809c5e9
5 pkgver=20190726.809c5e9
6 pkgrel=44
7 pkgdesc="platform library for external kodi addons"
8 arch=('x86_64')
9 url='https://github.com/xbmc/kodi-platform'
10 license=('GPL')
11 makedepends=('git' 'cmake' 'kodi-dev')
12 options=(!lto)
13 source=("$pkgname::git+https://github.com/xbmc/kodi-platform.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17     cd "$pkgname"
18     git log -1 --date=short --format="%cd.%h" | tr -d '-'
21 build() {
22     cd "$pkgname"
23     cmake \
24         -DCMAKE_INSTALL_PREFIX=/usr \
25         -DCMAKE_BUILD_TYPE=Release \
26         -DBUILD_SHARED_LIBS=1 \
27         -DUSE_LTO=1 \
28         .
29     make
32 package() {
33     depends=('kodi' 'p8-platform')
34     cd "$pkgname"
35     make DESTDIR="$pkgdir/" install