archrelease: copy trunk to community-any
[ArchLinux/community.git] / ktimetracker / trunk / PKGBUILD
blobc8cde696f54bb647cef63fb0ffdb4cbebe64a0a0
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=ktimetracker
4 pkgver=5.0.1
5 pkgrel=1
6 pkgdesc='Todo management and time tracker'
7 url='https://userbase.kde.org/KTimeTracker'
8 license=(GPL2)
9 arch=(x86_64)
10 depends=(kio kcalendarcore kidletime hicolor-icon-theme)
11 makedepends=(extra-cmake-modules kdoctools)
12 source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
13 sha256sums=('02e8620164357e594e135e20d8efd3987cc9c31a817c25e5555914e0971be64a'
14             'SKIP')
15 validpgpkeys=(D7A4AE3E9A5A18C98F36477DC7AF5D57818E49C3) # Alexander Potashev <aspotashev@gmail.com>
17 prepare() {
18   mkdir -p build
21 build() {
22   cd build
23   cmake ../$pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   make
28 package() {
29   cd build
30   make DESTDIR="$pkgdir" install