archrelease: copy trunk to community-any
[ArchLinux/community.git] / lib32-glib2 / trunk / PKGBUILD
blobff77c5080df6a3edf98c1c70aeaeeeaf9a3172d7
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Pierre Schmitz <pierre@archlinux.de>
4 # Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
6 pkgbase=lib32-glib2
7 pkgname=(lib32-glib2)
8 pkgver=2.76.2
9 pkgrel=1
10 pkgdesc="Low level core library - 32-bit"
11 url="https://wiki.gnome.org/Projects/GLib"
12 license=(LGPL)
13 arch=(x86_64)
14 depends=(
15   glib2
16   lib32-libffi
17   lib32-pcre2
18   lib32-util-linux
19   lib32-zlib
21 makedepends=(
22   gettext
23   git
24   gtk-doc
25   lib32-dbus
26   lib32-libelf
27   meson
28   python
29   shared-mime-info
30   util-linux
32 checkdepends=(
33   desktop-file-utils
34   lib32-glib2
36 options=(
37   debug
39 _commit=41ae5b5632ce9f6b2b5613ec1912821f769166c2  # tags/2.76.2^0
40 source=(
41   "git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
42   "git+https://gitlab.gnome.org/GNOME/gvdb.git"
43   0002-glocalfile-Sum-apparent-size-only-for-files-and-syml.patch
44   0003-tests-file-Do-not-rely-on-du-bytes-behaviour.patch
45   gio-querymodules-32.hook
47 b2sums=('SKIP'
48         'SKIP'
49         '6bcbcba60208162f7221701d6a642eabfc92c2fc6a476bcb42da5967577f8f0c75b688d149be01c9c48cd644aafa7fbdd63d9086385b8f7607fc981756d71a68'
50         '257bf37d304cc161dedcde0a2c4d01e297f8263cde48b49d3ee47ca95a8fb9ad44bbb9bf99da51ec766ffb6f9d502e0a8fdc6b86346e6755373ee515e23b9419'
51         '678ea2d010fd64b6c55106510096363c54c357d65615c666e9cc3a0e280c0878257a45e646dd88f6bdd0623f7268c4afd2d4f98f82a5489bbfc028c5864252f1')
53 pkgver() {
54   cd glib
55   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
58 prepare() {
59   cd glib
61   # fix test suite issues with coreutils >=9.2
62   # https://gitlab.gnome.org/GNOME/glib/-/merge_requests/3358
63   git apply -3 ../0002-glocalfile-Sum-apparent-size-only-for-files-and-syml.patch
64   git apply -3 ../0003-tests-file-Do-not-rely-on-du-bytes-behaviour.patch
66   git submodule init
67   git submodule set-url subprojects/gvdb "$srcdir/gvdb"
68   git -c protocol.file.allow=always submodule update
71 build() {
72   local meson_options=(
73     --libdir=/usr/lib32
74     -D glib_debug=disabled
75     -D gtk_doc=false
76     -D man=false
77     -D selinux=disabled
78     -D sysprof=disabled
79   )
81   export CC="gcc -m32 -mstackrealign"
82   export CXX="g++ -m32 -mstackrealign"
83   export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
85   # Produce more debug info: GLib has a lot of useful macros
86   CFLAGS+=" -g3"
87   CXXFLAGS+=" -g3"
89   arch-meson glib build "${meson_options[@]}"
90   meson compile -C build
93 check() {
94   meson test -C build --no-suite flaky --no-suite slow --print-errorlogs
97 package_lib32-glib2() {
98   depends+=(
99     libffi.so
100     libmount.so
101   )
102   provides+=(libg{lib,io,module,object,thread}-2.0.so)
104   meson install -C build --destdir "$pkgdir"
106   rm -r "$pkgdir"/usr/{lib,share,include}
107   find "$pkgdir/usr/bin" -type f -not -name gio-querymodules -printf 'Removing %P\n' -delete
108   mv "$pkgdir"/usr/bin/gio-querymodules{,-32}
110   install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
111   touch "$pkgdir/usr/lib32/gio/modules/.keep"
114 # vim:set sw=2 sts=-1 et: