archrelease: copy trunk to community-any
[ArchLinux/community.git] / lib32-rest / trunk / PKGBUILD
blob7eb0524268f7684b4f1e262b324ef6abcbc5ae80
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: GordonGR <ntheo1979@gmail.com>
3 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
5 pkgname=lib32-rest
6 pkgver=0.8.1
7 pkgrel=4
8 pkgdesc='A helper library for RESTful services'
9 arch=(x86_64)
10 url=https://www.gtk.org/
11 license=(GPL2)
12 depends=(
13   lib32-libsoup
14   rest
16 makedepends=(
17   git
18   gtk-doc
20 _tag=2971b3b92701f70fc368ad64bd25cefaea043f87
21 source=(git+https://gitlab.gnome.org/GNOME/librest.git#tag=${_tag})
22 b2sums=(SKIP)
24 prepare() {
25   cd librest
26   NOCONFIGURE=1 ./autogen.sh
29 pkgver() {
30   cd librest
31   git describe --tags
34 build() {
35   cd librest
37   export CC='gcc -m32'
38   export CXX='g++ -m32'
39   export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
41   ./configure \
42     --prefix=/usr \
43     --libdir=/usr/lib32 \
44     --disable-introspection \
45     --disable-gtk-doc
46   make
49 package() {
50   make DESTDIR="${pkgdir}" -C librest install
51   rm -rf "${pkgdir}"/usr/{include,share}
54 # vim: ts=2 sw=2 et: