archrelease: copy trunk to community-any
[ArchLinux/community.git] / lib32-sdl2_image / trunk / PKGBUILD
blob406df397d8d76c8efd52938f85237522c02ac376
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: carstene1ns <arch.carsten@teibes.de>
3 # Contributor: Jameson Pugh <imntreal@gmail.com>
5 pkgname=lib32-sdl2_image
6 pkgver=2.6.3
7 pkgrel=1
8 pkgdesc='A simple library to load images of various formats as SDL surfaces'
9 arch=(x86_64)
10 url=https://www.libsdl.org/projects/SDL_image/
11 license=(MIT)
12 depends=(
13   lib32-glibc
14   lib32-libjpeg
15   lib32-libpng
16   lib32-libtiff
17   lib32-sdl2
18   lib32-libwebp
19   sdl2_image
21 makedepends=(git)
22 _tag=d3c6d5963dbe438bcae0e2b6f3d7cfea23d02829
23 source=(git+https://github.com/libsdl-org/SDL_image.git#tag=${_tag})
24 b2sums=(SKIP)
26 prepare() {
27   cd SDL_image
28   ./autogen.sh
31 pkgver() {
32   cd SDL_image
33   git describe --tags | sed 's/^release-//'
36 build() {
37   cd SDL_image
38   export CC='gcc -m32'
39   export CXX='g++ -m32'
40   export PKG_CONFIG=i686-pc-linux-gnu-pkg-config
41   ./configure \
42     --prefix=/usr \
43     --libdir=/usr/lib32 \
44     --disable-static \
45     --disable-jxl
46   make
49 package() {
50   make DESTDIR="${pkgdir}" -C SDL_image install
51   rm -rf "${pkgdir}"/usr/include
52   install -dm 755 "${pkgdir}"/usr/share/licenses
53   ln -s sdl2_image "$pkgdir"/usr/share/licenses/lib32-sdl2_image
56 # vim: ts=2 sw=2 et: