archrelease: copy trunk to community-any
[ArchLinux/community.git] / lib32-sdl_image / trunk / PKGBUILD
blobdd6a1b9566b2d9aab47dad369f0fb002992ad5cb
1 # Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
2 # Contributor: SpepS <dreamspepser at yahoo dot it>
4 _pkgbasename=sdl_image
5 pkgname=lib32-$_pkgbasename
6 pkgver=1.2.12
7 pkgrel=8
8 pkgdesc="A simple library to load images of various formats as SDL surfaces (32-bit)"
9 url="https://www.libsdl.org/projects/SDL_image/"
10 arch=(x86_64)
11 license=(custom)
12 depends=('lib32-sdl>=1.2.13' lib32-libpng 'lib32-libjpeg-turbo' lib32-libtiff lib32-zlib "$_pkgbasename")
13 provides=('libSDL_image-1.2.so')
14 source=(https://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz)
15 sha256sums=('0b90722984561004de84847744d566809dbb9daf732a9e503b91a1b5a84e5699')
17 build() {
18   export CC='gcc -m32'
19   export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
21   cd SDL_image-$pkgver
22   ./configure --prefix=/usr --disable-static --libdir=/usr/lib32
23   make
26 package() {
27   cd SDL_image-$pkgver
28   make DESTDIR="$pkgdir" install
29   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
30   rm -rf "$pkgdir/usr/include"
33 # vim: sw=2:ts=2 et: