archrelease: copy trunk to community-any
[ArchLinux/community.git] / libgexiv2 / trunk / PKGBUILD
blob39d2a7fe0457c5d3434b00a00a837514ece5c313
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=libgexiv2
5 pkgver=0.14.0
6 pkgrel=4
7 pkgdesc='GObject-based wrapper around the Exiv2 library'
8 url='https://wiki.gnome.org/Projects/gexiv2'
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(exiv2 glib2)
12 makedepends=(gobject-introspection meson python-gobject vala)
13 source=("https://gitlab.gnome.org/GNOME/gexiv2/-/archive/gexiv2-$pkgver/gexiv2-gexiv2-$pkgver.tar.bz2")
14 b2sums=('154c8e870e7ef9189268a1c3dc3ed9cf0da933491dc874c6d28b4db1a0126a12fe9ca8cd03ba5bc33b535b9094a6c859e56a8f9f648703c7add1c5fd02a9a168')
17 build() {
18   arch-meson gexiv2-gexiv2-$pkgver build -D gtk_doc=true
19   meson compile -C build
22 check() {
23   meson test -C build --print-errorlogs
26 package() {
27   depends+=(libg{lib,object,io}-2.0.so libexiv2.so)
28   provides+=(libgexiv2.so)
29   meson install -C build --destdir "$pkgdir"