archrelease: copy trunk to community-any
[ArchLinux/community.git] / libicns / trunk / PKGBUILD
blobaef4eb640049ff16ad5ee82eef7df6a78aca4acf
1 # Maintainer: Brett Cornwall <ainola@archlinux.org>
2 # Contributor: Justin Dray
3 # Contributor: Andy Kluger
4 # Contributor: Alexander 'hatred' Drozdov
5 # Contributor: G_Syme
6 # Contributor: SpepS
7 # Contributor: Bastien Dejean
9 pkgname=libicns
10 pkgver=0.8.1
11 pkgrel=10
12 pkgdesc='Library for manipulating icns/IconFamily files'
13 arch=('x86_64')
14 url='https://icns.sourceforge.io/'
15 license=('LGPL' 'GPL2')
16 depends=('libpng' 'jasper')
17 source=("https://downloads.sf.net/icns/$pkgname-$pkgver.tar.gz")
18 sha256sums=('335f10782fc79855cf02beac4926c4bf9f800a742445afbbf7729dab384555c2')
20 build() {
21     cd "$pkgname-$pkgver"
22     ./configure --prefix=/usr
23     make
26 package() {
27     cd "$pkgname-$pkgver"
28     make DESTDIR="$pkgdir" install