archrelease: copy trunk to community-any
[ArchLinux/community.git] / libmanette / trunk / PKGBUILD
blob16a5ddf9d10e07540397ceb46359e21c3b33f60a
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=libmanette
4 pkgver=0.2.6
5 pkgrel=4
6 pkgdesc='Simple GObject game controller library'
7 arch=('x86_64')
8 url='https://gnome.pages.gitlab.gnome.org/libmanette/'
9 license=('LGPL2.1')
10 depends=('libevdev' 'libgudev')
11 makedepends=('gobject-introspection' 'meson' 'systemd' 'vala')
12 source=("https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz")
13 sha256sums=('63653259a821ec7d90d681e52e757e2219d462828c9d74b056a5f53267636bac')
15 build() {
16   arch-meson $pkgname-$pkgver build -D doc=true
17   meson compile -C build
20 package() {
21   meson install -C build --destdir "$pkgdir"