archrelease: copy trunk to community-any
[ArchLinux/community.git] / libressl / trunk / PKGBUILD
blob073c50806a3d77e8c03093f6cba03ffacd636cf9
1 # Maintainer: Levente Polyak <anthraxx@archlinux.org>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Maintainer: T.J. Townsend <blakkheim@archlinux.org>
4 # Contributor: Maarten de Vries <maarten@de-vri.es>
5 # Contributor: Reventlov <contact@volcanis.me>
6 # Contributor: kpcyrd <git@rxv.cc>
8 pkgname=libressl
9 pkgver=3.7.2
10 pkgrel=1
11 pkgdesc="Free version of the TLS/crypto stack forked from OpenSSL"
12 arch=(x86_64)
13 url="https://www.libressl.org/"
14 license=(ISC custom:OpenSSL)
15 depends=(glibc)
16 optdepends=(ca-certificates)
17 backup=(etc/libressl/openssl.cnf)
18 source=(https://cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz{,.asc})
19 sha256sums=('b06aa538fefc9c6b33c4db4931a09a5f52d9d2357219afcbff7d93fe12ebf6f7'
20             'SKIP')
21 validpgpkeys=(A1EB079B8D3EB92B4EBD3139663AF51BD5E4D8D5) # Brent Cook <bcook@openbsd.org>
23 prepare() {
24     cd ${pkgname}-${pkgver}
25     autoreconf -vfi
28 build() {
29     cd ${pkgname}-${pkgver}
30     ./configure \
31         --prefix=/usr \
32         --with-openssldir=/etc/libressl \
33         --libdir=/usr/lib/libressl \
34         --includedir=/usr/include/libressl \
35         --program-prefix "libressl-"
36     sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
37     make
40 check() {
41     cd ${pkgname}-${pkgver}
42     make check
45 package() {
46     cd ${pkgname}-${pkgver}
47     make DESTDIR="${pkgdir}" install
48     install -Dm644 COPYING -t "${pkgdir}"/usr/share/licenses/${pkgname}/
50     # Remove symlink man pages that point to OpenSSL ones since the prefix is not accounted for
51     for manlink in $(find -L "${pkgdir}"/usr/share/man/man3/ -type l) ;
52     do
53         rm "${manlink}" ;
54     done
57 # vim: ts=4 sw=4 et: