1 # Maintainer: Levente Polyak <anthraxx@archlinux.org>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Maintainer: T.J. Townsend <blakkheim@archlinux.org>
4 # Contributor: Maarten de Vries <maarten@de-vri.es>
5 # Contributor: Reventlov <contact@volcanis.me>
6 # Contributor: kpcyrd <git@rxv.cc>
11 pkgdesc="Free version of the TLS/crypto stack forked from OpenSSL"
13 url="https://www.libressl.org/"
14 license=(ISC custom:OpenSSL)
16 optdepends=(ca-certificates)
17 backup=(etc/libressl/openssl.cnf)
18 source=(https://cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${pkgver}.tar.gz{,.asc})
19 sha256sums=('b06aa538fefc9c6b33c4db4931a09a5f52d9d2357219afcbff7d93fe12ebf6f7'
21 validpgpkeys=(A1EB079B8D3EB92B4EBD3139663AF51BD5E4D8D5) # Brent Cook <bcook@openbsd.org>
24 cd ${pkgname}-${pkgver}
29 cd ${pkgname}-${pkgver}
32 --with-openssldir=/etc/libressl \
33 --libdir=/usr/lib/libressl \
34 --includedir=/usr/include/libressl \
35 --program-prefix "libressl-"
36 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
41 cd ${pkgname}-${pkgver}
46 cd ${pkgname}-${pkgver}
47 make DESTDIR="${pkgdir}" install
48 install -Dm644 COPYING -t "${pkgdir}"/usr/share/licenses/${pkgname}/
50 # Remove symlink man pages that point to OpenSSL ones since the prefix is not accounted for
51 for manlink in $(find -L "${pkgdir}"/usr/share/man/man3/ -type l) ;