archrelease: copy trunk to community-any
[ArchLinux/community.git] / libretro-bsnes-hd / repos / community-x86_64 / PKGBUILD
blob00bba8ca57fa5fe05ba200881773f5187dd1d843
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=libretro-bsnes-hd
4 pkgver=53
5 pkgrel=1
6 pkgdesc='Super Nintendo Entertainment System core'
7 arch=(x86_64)
8 url=https://github.com/DerKoun/bsnes-hd
9 license=(GPL3)
10 groups=(libretro)
11 depends=(
12   gcc-libs
13   libretro-core-info
15 makedepends=(git)
16 _commit=f46b6d6368ea93943a30b5d4e79e8ed51c2da5e8
17 source=(
18   libretro-bsnes-hd::git+https://github.com/DerKoun/bsnes-hd.git#commit=${_commit}
19   libretro-bsnes-hd-flags.patch
21 sha256sums=(
22   SKIP
23   8108ce3da95d9a7fd9fae00d2db042f1053e60d19fe87813b7ddf0aa5313cdd8
26 prepare() {
27   cd libretro-bsnes-hd
29   patch -Np1 -i ../libretro-bsnes-hd-flags.patch
32 pkgver() {
33   cd libretro-bsnes-hd
35   git rev-list --count HEAD
38 build() {
39   make -C libretro-bsnes-hd/bsnes -f GNUmakefile target=libretro binary=library local=false platform=linux
42 package() {
43   install -Dm 644 libretro-bsnes-hd/bsnes/out/bsnes_hd_beta_libretro.so -t "${pkgdir}"/usr/lib/libretro/
46 # vim: ts=2 sw=2 et: