1 # Maintainer: Jonas Witschel <diabonas@archlinux.org>
4 _tag=fccd9f0ec5febf75ccec2742e75889cdfa329e53 # git rev-parse "v$pkgver"
6 pkgdesc='Library providing a software emulation of a Trusted Platform Module (TPM 1.2 and TPM 2.0)'
8 url='https://github.com/stefanberger/libtpms'
12 source=("git+$url.git?signed#tag=$_tag")
14 validpgpkeys=('B818B9CADF9089C2D5CEC66B75AD65802A0B4211') # Stefan Berger <stefanb@linux.vnet.ibm.com>
18 git describe | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
23 autoreconf --install --force
28 ./configure --prefix=/usr --with-openssl --with-tpm2
39 make DESTDIR="$pkgdir" install
40 install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"