1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
3 # Contributor: Andy Weidenbaum <archbaum@gmail.com>
8 pkgdesc='WebSocket library'
12 makedepends=(python-sphinx)
14 optdepends=('nettle: needed for wslay_testclient')
15 url='https://github.com/tatsuhiro-t/wslay'
17 source=("$pkgname-$pkgver.tar.bz2::https://github.com/tatsuhiro-t/wslay/releases/download/release-$pkgver/wslay-$pkgver.tar.bz2"
19 b2sums=('e5b5e7435e1e3a82cef4407f2a5fbcf4168f2814546074d8ee5aa70f36acabc648bc58f14aaee53bc6be7ab7e18c39a4f8e16fba507dc85f19ee4f79a827be6e'
20 '12dc00c3dfcf29a0263b93638164ab9e99a9672962714392cf8f28421498d138a83779a267f59892b579f66dfc4b7fca8c8b1a3662040d9dc29d1841ebe42ea9')
24 patch -Np1 -i ../sphinx-4.patch
31 --libexecdir=/usr/lib/wslay \
32 --localstatedir=/var/lib/wslay \
35 --sharedstatedir=/usr/share/wslay \
47 make DESTDIR="$pkgdir" install
48 install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
49 # rename example executables
50 cd "$pkgdir/usr/bin" && find * -type f -exec mv -v {} wslay_{} \;