1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
6 pkgdesc='Driver and GUI for LMS7002M-based SDR platforms (LimeSDR, etc.)'
8 url='https://github.com/myriadrf/LimeSuite'
10 depends=('sqlite3' 'wxwidgets-gtk3' 'freeglut' 'libusb' 'soapysdr' 'wget' 'gnuplot' 'glew' 'fltk')
11 makedepends=('cmake' 'doxygen' 'octave')
12 optdepends=('octave: Octave plugin')
13 provides=('soapylms7')
14 conflicts=('soapylms7')
15 source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
16 sha512sums=('526d99f8f835bfab021b29b7ffc5bf49d05d7b2211646c3474c35b8dcf9bfb2555b024bf5fa7bc7db2042003415e00fb0423f3ba15244df6940023304c9cdaff')
21 sed -i 's|MODE="660", GROUP="plugdev"|MODE="666"|g' udev-rules/64-limesuite.rules
25 mkdir -p LimeSuite-$pkgver/build
26 cd LimeSuite-$pkgver/build
29 -DCMAKE_INSTALL_PREFIX=/usr \
30 -DCMAKE_BUILD_TYPE=Release \
31 -DENABLE_UTILITIES=True \
32 -DENABLE_LIME_UTIL=True \
33 -DCMAKE_SKIP_RPATH=True \
34 -DENABLE_DESKTOP=False \
35 -DENABLE_SOAPY_LMS7=True \
36 -DENABLE_PCIE_XILLYBUS=True \
37 -DENABLE_QUICKTEST=True \
38 -DENABLE_MCU_TESTBENCH=True \
41 -DENABLE_STREAM_UNITE=True \
42 -DENABLE_EXAMPLES=True \
43 -DENABLE_HEADERS=True \
45 -DENABLE_OCTAVE=True \
46 -DENABLE_API_DOXYGEN=True \
47 -DLIME_SUITE_EXTVER=$pkgver
49 # -DENABLE_EVB7COM=True \
50 # -DENABLE_REMOTE=True \
56 cd LimeSuite-$pkgver/build
58 make DESTDIR="$pkgdir" install
61 install -Dm 644 ../udev-rules/64-limesuite.rules "$pkgdir"/etc/udev/rules.d/64-limesuite.rules
63 # Install icons and .desktop file
64 install -Dm 644 ../Desktop/lime-suite-128.png "$pkgdir"/usr/share/pixmaps/lime-suite.png
65 install -Dm 755 ../Desktop/lime-suite.desktop "$pkgdir"/usr/share/applications/lime-suite.desktop
67 # Install documentation
68 install -dm 755 "$pkgdir"/usr/share/doc/$pkgname
69 cp -r --no-preserve=ownership ../docs/LMS_API_Documentation/* "$pkgdir"/usr/share/doc/$pkgname