archrelease: copy trunk to community-any
[ArchLinux/community.git] / liquidshell / repos / community-x86_64 / PKGBUILD
blobd794cb906edf1f73f6f82d1c7c25b09aa9ecd713
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=liquidshell
4 pkgver=1.8.1
5 pkgrel=1
6 pkgdesc='Basic desktop shell using QtWidgets'
7 arch=(x86_64)
8 url='https://invent.kde.org/system/liquidshell'
9 license=(GPL3)
10 depends=(kcmutils knewstuff networkmanager-qt bluez-qt packagekit-qt5 hicolor-icon-theme)
11 makedepends=(extra-cmake-modules)
12 source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('a741219050e96f44078770cc7042e50413015b1b9a331037e289871b8741c632'
14             'SKIP')
15 validpgpkeys=(3DAB43DA42E08DE44800A2891E674FA08DFB0F86) # Martin Koller <kollix@aon.at>
17 build() {
18   cmake -B build -S $pkgname-$pkgver
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build