archrelease: copy trunk to community-any
[ArchLinux/community.git] / lldpd / trunk / PKGBUILD
blobd815e1927f06b6ff377b27c86b048fd195d9cfd0
1 # Maintainer: Sébastien "Seblu" Luttringer
2 # Contributor: Brian Bidulock <bidulock@openss7.org>
4 pkgname=lldpd
5 pkgver=1.0.16
6 pkgrel=1
7 pkgdesc='802.1ab implementation (LLDP) to help you locate neighbors'
8 arch=('x86_64')
9 url='https://vincentbernat.github.io/lldpd/'
10 license=('custom:ISC' 'GPL')
11 depends=('glibc' 'libevent' 'libbsd' 'zlib' 'openssl' 'pciutils' 'perl'
12          'libxml2' 'net-snmp' 'jansson')
13 makedepends=('systemd')
14 backup=('etc/lldpd.conf')
15 validpgpkeys=('AEF2348766F371C689A7360095A42FE8353525F9') # Vincent Bernat <bernat@luffy.cx>
16 source=("https://media.luffy.cx/files/lldpd/lldpd-${pkgver}.tar.gz"
17         "lldpd-${pkgver}.tar.gz.sig::https://media.luffy.cx/files/lldpd/lldpd-${pkgver}.tar.gz.gpg"
18         'lldpd.tmpfiles.conf')
19 sha256sums=('e3b391650c7ba67cea2fe84d67fdb4d7fc8aa1ec5cf86eb8bb984711df8465a9'
20             'SKIP'
21             'df64ebadacb832c4a9dcbdd531848ae70c21d67d309c7397163ba8db7e31248b')
23 build() {
24   cd "${srcdir}/${pkgname}-${pkgver}/"
26   ./configure \
27     --prefix=/usr \
28     --sbindir=/usr/bin \
29     --sysconfdir=/etc \
30     --localstatedir=/var \
31     --with-lldpd-ctl-socket=/run/lldpd/socket \
32     --with-lldpd-pid-file=/run/lldpd/pid \
33     --with-privsep-chroot=/run/lldpd/chroot \
34     --with-privsep-group=lldpd \
35     --with-privsep-user=lldpd \
36     --with-readline \
37     --with-snmp \
38     --with-xml \
39     --without-seccomp
40   make
43 check() {
44   cd "${srcdir}/${pkgname}-${pkgver}/"
46   make check
49 package() {
50   cd "${srcdir}/${pkgname}-${pkgver}/"
51   
52   make DESTDIR="${pkgdir}" install
54   # re-introduce tmpfiles file untill resolved upstream...
55   # https://github.com/vincentbernat/lldpd/pull/311
56   install -D -m 0644 "${srcdir}/lldpd.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/lldpd.conf"
58   # config stuff
59   install -D -m 0644 /dev/null "${pkgdir}/etc/lldpd.conf"
60   install -d -m 0755 "${pkgdir}/etc/lldpd.d"
62   # license
63   install -D -m 0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
66 # vim:set ts=2 sw=2 et: