archrelease: copy trunk to community-any
[ArchLinux/community.git] / log4cplus / trunk / PKGBUILD
blob97f041b4213b9604b221526f9b2e90384d2cf497
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Alexey Galakhov <agalakhov at gmail dot com>
3 # Contributor: Andreas Baumann <abaumann at yahoo dot com>
5 pkgname=log4cplus
6 pkgver=2.1.0
7 pkgrel=1
8 pkgdesc="A C++ logger very close to Java's log4j"
9 arch=('x86_64')
10 url="http://log4cplus.sourceforge.net/"
11 license=('GPL')
12 depends=('gcc-libs')
13 source=("https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.xz")
14 sha512sums=('a0dc2cad2f10042ea561075adb7adcde5aedae4e4a3bf707fba4b619961e4e4c126410e1ecc003213a07e03d2576f1825444f76a26b7964b5656efb5dfc50637')
16 build() {
17   cd ${pkgname}-${pkgver}
19   ./configure \
20     --prefix=/usr \
21     --with-working-locale
23   make
26 package() {
27   cd ${pkgname}-${pkgver}
29   make install DESTDIR="${pkgdir}"