archrelease: copy trunk to community-any
[ArchLinux/community.git] / log4cpp / trunk / PKGBUILD
blob7b65ee96cfa31b619b75c3706f0ae55581f961f2
1 # Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
2 # Contributor : Geraud Le Falher <daureg@gmail.com>
4 pkgname=log4cpp
5 pkgver=1.1.4
6 pkgrel=1
7 pkgdesc="A library of C++ classes for flexible logging to files, syslog, IDSA and other destinations."
8 arch=('x86_64')
9 url="http://log4cpp.sourceforge.net/"
10 license=('LGPL')
11 depends=('gcc-libs' 'libnsl')
12 source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
13 sha256sums=('696113659e426540625274a8b251052cc04306d8ee5c42a0c7639f39ca90c9d6')
15 build() {
16   cd "$srcdir/$pkgname"
17   ./configure --prefix=/usr --disable-doxygen --disable-dot --without-idsa
18   make
21 package() {
22   cd "$srcdir/$pkgname"
23   make DESTDIR="$pkgdir" install