archrelease: copy trunk to community-any
[ArchLinux/community.git] / lrzip / trunk / PKGBUILD
blobbd8c7a5c12fb2fb0104aeb31d0fc7d6f22d62da5
1 # Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
2 # Contributor: graysky <graysky@archlinux.us>
3 # Contributor: <kastor@fobos.org.ar>
5 pkgname=lrzip
6 pkgver=0.651
7 pkgrel=2
8 pkgdesc='Multi-threaded compression with rzip/lzma, lzo, and zpaq'
9 url='https://github.com/ckolivas/lrzip'
10 license=('GPL')
11 arch=('x86_64')
12 depends=('lzo')
13 makedepends=('git')
14 source=("git+https://github.com/ckolivas/lrzip#tag=v${pkgver}"
15         "${pkgname}-${pkgver}-CVE-2018-5786.patch::https://github.com/ckolivas/lrzip/commit/3495188cd8f2215a9feea201f3e05c1341ed95fb.patch")
16 sha256sums=('SKIP'
17             '8573ff8dd049c91cd0e6d754683e889ae439119cb9e738241dedd369c280a6fc')
19 prepare() {
20   cd "${pkgname}"
21   patch -Np1 < "../${pkgname}-${pkgver}-CVE-2018-5786.patch"
24 build() {
25   cd "${pkgname}"
27   CFLAGS="$CFLAGS -fomit-frame-pointer"
28   CXXFLAGS="$CXXFLAGS -fomit-frame-pointer"
30   ./autogen.sh --prefix=/usr "$flags"
31   make
34 check() {
35   make -C "${pkgname}" -k check
38 package() {
39   make -C "${pkgname}" DESTDIR="${pkgdir}" install-strip
42 # vim: ts=2 sw=2 et:
43 # getver: -u 3 github.com/ckolivas/lrzip/blob/master/ChangeLog