1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: wenLiangcan <boxeed at gmail dot com>
5 _rockname=${pkgbase#lua-}
6 pkgname=("$pkgbase" "lua51-$_rockname" "lua52-$_rockname" "lua53-$_rockname")
10 pkgdesc='A binding for the linenoise command line library'
12 url="https://github.com/hoelzro/$pkgbase"
20 _archive="$pkgbase-$pkgver"
21 _rock="$_rockname-$pkgver-$_rockrel.linux-$CARCH.rock"
22 _rockspec="$_rockname-$pkgver-$_rockrel.rockspec"
23 source=("$_archive.tar.gz::$url/archive/$pkgver.tar.gz")
24 sha256sums=('cc1cdb4047edd056a10dcdeec853dbaf5088e2202941d579e4592584d733f09c')
28 for LUAVER in 5.{1,2,3,4}; do
29 luarocks --lua-version "$LUAVER" \
30 make --pack-binary-rock --deps-mode none -- "$_rockspec"
31 install -Dm0644 -t "lua-$LUAVER/" "$_rock"
37 depends=("${pkgname%-*}")
38 luarocks --lua-version "$1" --tree "$pkgdir/usr/" \
39 install --deps-mode none --no-manifest -- "lua-$1/$_rock"
40 install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
43 package_lua-linenoise() {
47 package_lua51-linenoise() {
51 package_lua52-linenoise() {
55 package_lua53-linenoise() {