archrelease: copy trunk to community-any
[ArchLinux/community.git] / lua-lut / repos / community-any / PKGBUILD
blob3807714456b8b63dfff2aa6ff5c7bbc36cd3aef4
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 pkgbase=lua-lut
4 _rockname=${pkgbase#lua-}
5 pkgname=("$pkgbase" "lua51-$_rockname" "lua52-$_rockname" "lua53-$_rockname")
6 pkgver=1.2.1
7 _rockrel=1
8 pkgrel=1
9 pkgdesc='Lubyk utility module'
10 arch=(any)
11 url="https://lubyk.github.io/lubyk/$_rockname.html"
12 license=(MIT)
13 _luadeps=(filesystem
14           lub)
15 makedepends=(lua
16              lua51
17              lua52
18              lua53
19              luarocks)
20 checkdepends=("${_luadeps[@]/#/lua-}")
21 _archive="$_rockname-REL-$pkgver"
22 source=("https://github.com/lubyk/$_rockname/archive/REL-$pkgver/$_archive.tar.gz")
23 sha256sums=('6f7fbe620995b49d59127cf354d9100c218744b91327345c2fa7777fb9871413')
25 check() {
26         cd "$_archive"
27         lua test/all.lua
30 _package() {
31         cd "$_archive"
32         depends=("${pkgname%-*}" "${_luadeps[@]/#/${pkgname%-*}-}")
33         luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
34                 make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
35         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
38 package_lua-lut() {
39         _package 5.4
42 package_lua53-lut() {
43         _package 5.3
46 package_lua52-lut() {
47         _package 5.2
50 package_lua51-lut() {
51         _package 5.1