archrelease: copy trunk to community-any
[ArchLinux/community.git] / lv2file / repos / community-x86_64 / PKGBUILD
blobad7d9f8ccacbff99125fa254fbadd41f9c8e4e3c
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
4 pkgname=lv2file
5 pkgver=0.95
6 pkgrel=2
7 pkgdesc="A simple program which you can use to apply effects to your audio files"
8 arch=(x86_64)
9 url="https://github.com/jeremysalwen/lv2file"
10 license=(GPL3)
11 groups=(
12   lv2-plugins
13   pro-audio
15 depends=(
16   argtable
17   glibc
19 makedepends=(
20   libsndfile
21   lilv
22   lv2
24 source=($url/archive/upstream/$pkgver/$pkgname-$pkgver.tar.gz)
25 sha512sums=('f166d018e7554cb2ae55bfa06b96b6e0cd69b2488e401951973cc278fc23a5edf6eaa7f7e39cdc18420035cebafe58737f44cd2f9fdf6533a0118853ed4e2d04')
26 b2sums=('a4dbb0e9aa680e751be60d415a86bf181f05688eb5ec5176aed25a8de3026a79ea46a2be9af563a8a1b58c24581acb90eaf222eca1b4b597466672683861a509')
28 build() {
29   make all -C $pkgname-upstream-$pkgver
32 package() {
33   depends+=(
34     lilv liblilv-0.so
35     libsndfile libsndfile.so
36   )
38   make DESTDIR="$pkgdir" install -C $pkgname-upstream-$pkgver
39   install -vDm 644 $pkgname-upstream-$pkgver/$pkgname.1 -t "$pkgdir/usr/share/man/man1/"
40   install -vDm 644 $pkgname-upstream-$pkgver/README -t "$pkgdir/usr/share/doc/$pkgname/"