archrelease: copy trunk to community-any
[ArchLinux/community.git] / lxde-common / trunk / PKGBUILD
blob298add0c8c01f00809b9952230e5a00c3a3c438e
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Juergen Hoetzel <juergen@archlinux.org>
6 pkgname=lxde-common
7 pkgver=0.99.2
8 pkgrel=3
9 pkgdesc='Common files of the LXDE Desktop'
10 arch=('any')
11 url='https://lxde.org/'
12 license=('GPL2')
13 groups=('lxde' 'lxde-gtk3')
14 backup=(etc/xdg/lxsession/LXDE/desktop.conf
15         etc/xdg/lxsession/LXDE/autostart)
16 makedepends=('intltool')
17 optdepends=('gnome-themes-standard: default GTK+ theme'
18             'lxde-icon-theme: default icon theme')
19 source=(https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.xz
20         dbus-update-environment.patch
21         default-config.patch)
22 sha256sums=('1cd9bc900960c995d48ffbbdc86ecffda7c806168c67aaa50c53113794234856'
23             '87f1413f5bb371de45451fc7f82f9f80a23c90f5799bed173ec31589824c03bb'
24             '6a31a706d0fd1cb168b495806bb4a646c019e3b9c4f6bc13aae9edb8b0372d9d')
26 prepare() {
27     cd $pkgname-$pkgver
28     patch -Np1 -i ../dbus-update-environment.patch
29     patch -Np1 -i ../default-config.patch
32 build() {
33     cd $pkgname-$pkgver
34     ./configure --sysconfdir=/etc --prefix=/usr
35     make
38 package() {
39     cd $pkgname-$pkgver
40     make DESTDIR="$pkgdir" install