archrelease: copy trunk to community-any
[ArchLinux/community.git] / lxhotkey / trunk / PKGBUILD
blob6793bc5c2733bc224a63d316ae1d4693441f1cad
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgbase=lxhotkey
4 pkgname=(lxhotkey lxhotkey-gtk3)
5 pkgver=0.1.1
6 pkgrel=2
7 pkgdesc='Keyboard shortcuts configurator (part of LXDE)'
8 arch=('x86_64')
9 license=('GPL2')
10 url='https://lxde.org/'
11 depends=('gtk2' 'gtk3' 'libfm')
12 makedepends=('intltool')
13 source=(https://downloads.sourceforge.net/lxde/$pkgbase-$pkgver.tar.xz)
14 sha256sums=('e065ce42996ce96dec3f28b6d8c5eecb9d183bebb355367ef3eae6db261026e5')
16 prepare() {
17   cd $pkgbase-$pkgver
18   ./autogen.sh
21 build() {
22   # GTK+ 2 version
23   [ -d gtk2 ] || cp -r $pkgbase-$pkgver gtk2
24   cd gtk2
25   ./configure --sysconfdir=/etc --prefix=/usr --with-gtk=2
26   make
28   cd "$srcdir"
29   # GTK+ 3 version
30   [ -d gtk3 ] || cp -r $pkgbase-$pkgver gtk3
31   cd gtk3
32   ./configure --sysconfdir=/etc --prefix=/usr --with-gtk=3
33   make
36 package_lxhotkey() {
37   groups=('lxde')
38   depends=('gtk2' 'libfm')
40   cd gtk2
41   make DESTDIR="$pkgdir" install
44 package_lxhotkey-gtk3() {
45   groups=('lxde-gtk3')
46   pkgdesc+=' (GTK+ 3 version)'
47   depends=('gtk3' 'libfm' 'libunistring')
48   conflicts=('lxhotkey')
50   cd gtk3
51   make DESTDIR="$pkgdir" install